Problem with notifications
Incident Report for Sandbox PayU GPO Europe
Resolved
This incident has been resolved.
Posted Nov 13, 2024 - 17:02 CET
Investigating
There is problem with notifications at the moment. We are working to fix the problem
Posted Nov 13, 2024 - 16:38 CET
This incident affected: Notifications.