Problem with payment via cards on Sandbox

Incident Report for Sandbox PayU GPO Europe

Resolved

This incident has been resolved.
Posted Mar 16, 2025 - 02:16 CET

Investigating

We have detected a partial service disruption at this page. As this disruption is ongoing, you may notice an increase in response times or other unexpected behaviours.
Posted Mar 16, 2025 - 02:02 CET
This incident affected: Payments (Cards integration).