Problem with payment via Credit/Buy now pay later - Twisto PL
Incident Report for Sandbox PayU PL
Resolved
This incident has been resolved.
Posted May 18, 2022 - 11:36 CEST
Investigating
We have detected a partial service disruption at this page. As this disruption is ongoing, you may notice an increase in response times or other unexpected behaviours.
Posted May 18, 2022 - 08:36 CEST
This incident affected: Credit (Pay later with Twisto (PL)).