Problem with payment via Credit/Buy now pay later - Twisto PL on Sandbox
Incident Report for Sandbox PayU PL
Resolved
This incident has been resolved.
Posted Mar 27, 2023 - 16:50 CEST
Investigating
We have detected a partial service disruption at this page. As this disruption is ongoing, you may notice an increase in response times or other unexpected behaviours.
Posted Mar 27, 2023 - 15:52 CEST
This incident affected: Credit (Pay later with Twisto (PL)).